Resolved
Login to dltHub is functional again, WorkOS has resolved the issue.
Investigating
Problem: Login for app.dlthub.com is timing out.
Impact: Users may not be able to log in or sign up. Users who were already logged in and whose access token expired may not reach app.dlthub.com. Users who were logged out cannot log in to dltHub platform.
Causes: WorkOS is having issues, preventing the login flow from opening reliably
Status: We are investigating and will provide an update in the next 60 minutes. (edited)