Resolved
Final fix has been deployed, redirects are working again (browser cache needs to be cleared for the fix to take effect)
Investigating
Redirects still resolving incorrectly, fix is being tested and will be deployed on the next working day
Investigating
Redirects on docs showed a 404 after restructuring CI. Hotfix deployed, longer-term fix in progress.